Actualmente tengo el siguienteC# ¿este diseño es "Correcto"?
if (!RunCommand(LogonAsAServiceCommand))
return;
if (!ServicesRunningOrStart())
return;
if (!ServicesStoppedOrHalt())
return;
if (!BashCommand(CreateRuntimeBashCommand))
return;
if (!ServicesStoppedOrHalt())
return;
if (!BashCommand(BootstrapDataBashCommand))
return;
if (!ServicesRunningOrStart())
return;
habría que ser más limpia de hacer esto? ¿es seguro?
if (
(RunCommand(LogonAsAServiceCommand))
&& (ServicesRunningOrStart())
&& (ServicesStoppedOrHalt())
&& (BashCommand(CreateRuntimeBashCommand))
&& (ServicesStoppedOrHalt())
&& (BashCommand(BootstrapDataBashCommand))
&& (ServicesRunningOrStart())
)
{
// code after "return statements" here
}
totalmente la misma y una cuestión de estilo, excepto que el primero es más fácil de depurar (y establecer puntos de interrupción). –
Estoy de acuerdo con @Kirk Woll, cuando están optimizados deberían ser lo mismo si el compilador/jitter es lo suficientemente inteligente. – leppie